[Python] Linux: errore wxPython durante installazione applicazione

Y3s y3s a katamail.com
Gio 31 Gen 2008 13:54:17 CET


Il giorno 31/gen/08, alle ore 12:57, Mr.SpOOn ha scritto:

> Salve,
> su Ubuntu Gutsy Gibbon (7.10) sto cercando di installare il  
> software pysoulseek.
>
> Quando provo a dare il comando
>
> python ./pyslsk
>
> ricevo il seguente errore:
>
> ./pyslsk:28: DeprecationWarning: The wxPython compatibility package is
> no longer automatically generated or actively maintained.  Please
> switch to the wx package as soon as possible.

Gli sviluppatori dovrebbero leggere anche i warning ;-)
Usare wxPython  deprecato gi da un po' (2.6 mi pare), sul mio  
sistema (mac osx) non funziona proprio, ma  specificato chiaramente  
che non viene pi mantenuto!

>   import wxPython.wx
> Can not find wxPython modules. Either wxPython is not
> installed, or it's not in Python's module search path (it could be  
> built
> for a different version of python interpreter for example). The  
> current
> search path is
> ['/home/ilsignorcarlo/pyslsk-1.2.7b', '/usr/lib/python25.zip',
> '/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2',
> '/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload',
> '/usr/local/lib/python2.5/site-packages',
> '/usr/lib/python2.5/site-packages',
> '/usr/lib/python2.5/site-packages/Numeric',
> '/usr/lib/python2.5/site-packages/gst-0.10',
> '/var/lib/python-support/python2.5',
> '/usr/lib/python2.5/site-packages/gtk-2.0',
> '/var/lib/python-support/python2.5/gtk-2.0',
> '/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode']
>

Prova a vedere in /usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode
Dovrebbe esserci un package (una directory insomma) wxPython. Se non  
c', mi sa che hai qualche problema con l'installazione di wxPython.

> Ho cercato un po' in giro e mi sembra che il problema stia nel fatto
> che dovrei aggiungere il path al PYTHONPATH, o qualcosa del genere, ma
> non sono riuscito a capire esattamente come e cosa devo aggiungere.
> Sapete aiutarmi?
> Grazie

Il path c',  l'ultima riga della lista di sopra, per c' qualche  
problema visto che non ti trova il package wxPython. Puoi provare a  
vedere se ci sono versioni vecchie di wxPython nei repository ubuntu,  
penso di si. Probabilmente installando una versione precedente  
dovresti risolvere il problema...

--
Antonio Valente




More information about the Python mailing list